You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2010-02-26 08:30:27

elu
Guest

elu said:

Problem with SAP connection

Tags: [development]

Hi,

i try to create a job with tSAPInput and i would add the SAP Java Connector in the Modules view, but i cannot see the Modules view. I have only Component, Repository, Contexts, Problems, Starte Job views on my screen. How can i open the modules view?

many thanks in advance
Erwin

#2 2010-03-01 04:18:40

shong
Talend Team


shong said:

Re: Problem with SAP connection

Hello
Go to windows-->show view-->talend and open modules viewer.
Here are some topic about SAP connector and SAP webinar,
http://www.talendforge.org/forum/viewtopic.php?id=4696.
http://www.talendforge.org/forum/viewtopic.php?id=4987.
http://www.talendforge.org/forum/viewtopic.php?id=8817.

Hope they are useful!!!

Best regards

          shong


Email:shong@talend.com
Choose Talend, Enjoy Talend!
New & Event: Talend Help Center
Talend-->the global leader of open source data management and application integration solutions!

Offline

#3 2010-03-15 14:28:04

elu
Member
1 post

elu said:

Re: Problem with SAP connection

Hello,

many thanks now it works, but only with the sapjco.jar and not with sapjco3.jar, which is newer.
Is it also possible to use sapjco3.jar ?
In the modules view it has the status "Unused".

many thanks again
elu

Offline

#4 2010-03-15 14:46:44

cantoine
Talend Team


cantoine said:

Re: Problem with SAP connection

Hi;

Yes you can use your own sapjco3.jar; indeed it's recommended.

The best way to use your own JAR is to rename this sapjco3.jar to sapjco.jar and copy it to the #Talend_Install#\plugins\org.talend.designer.components.localprovider_3.2.3.r35442\components\tSAPInput.

Best regards;

Offline

#5 2010-11-08 18:58:26

Stefan_W
Member
6 posts

Stefan_W said:

Re: Problem with SAP connection

I use TIS 4.1.1 on Linux x86_64 with Win 32 bit client.

sapjco.jpg

Cound'nt succeed with sapjco3.jar even when it's renamed.
tSAPConnection is using com.sap.mw.jco.JCO but Java Connector v3 has com.sap.conn.jco.JCo

Is there any way? Don't know if I can still get old version in the marketplace.

#43291 Shong said at 2010-07-29 there is no sapjco3 support. Any news?
#38408 cantoine said at 2010-03-15 sapjco3 is recommended and you can rename it.

2010-11-09 I got Java Connector v2.1.9 but the question is still legitimate.

Last edited by Stefan_W (2010-11-09 12:37:49)

Offline

#6 2010-12-20 11:42:57

Aquagest
Member
5 posts

Aquagest said:

Re: Problem with SAP connection

Hi everybody,

I am as confused as Stefan.

Which JCo versions are supported?

I think everybody would appreciate some clarity on the issue...

Offline

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy