You are not logged in.

#1 2012-10-30 20:41:55

dneuman64
Member
20 posts

[resolved] Error when starting Talend Runtime

Hello, I just installed Talend Runtime 5.1.1 on a new linux server running RHEL 6.2.  When I start Talend-Runtime I see the following error in the log, does anyone know how to solve this?

12:59:56,392 | ERROR | observer.server) | oring.jmx.server.OsInfoRetriever  237 | 188 - org.talend.monitoring.server - 5.1.1 | Exception when starting Sigar monitoring
java.lang.UnsatisfiedLinkError: org.hyperic.sigar.Sigar.getNativeVersion()Ljava/lang/String;
        at org.hyperic.sigar.Sigar.getNativeVersion(Native Method)[191:org.hyperic.sigar:1.6.4]
        at org.hyperic.sigar.Sigar.<clinit>(Sigar.java:101)[191:org.hyperic.sigar:1.6.4]
        at sigar.CPUMonitoringData.<clinit>(CPUMonitoringData.java:32)[188:org.talend.monitoring.server:5.1.1]
        at sigar.SigarCpuInfo.computeCPUMonitoringData(SigarCpuInfo.java:152)[188:org.talend.monitoring.server:5.1.1]
        at sigar.SigarCpuInfo.access$000(SigarCpuInfo.java:31)[188:org.talend.monitoring.server:5.1.1]
        at sigar.SigarCpuInfo$1.run(SigarCpuInfo.java:129)[188:org.talend.monitoring.server:5.1.1]
        at sigar.SigarCpuInfo.startMonitoring(SigarCpuInfo.java:133)[188:org.talend.monitoring.server:5.1.1]
        at org.talend.monitoring.jmx.server.OsInfoRetriever.startSigarMonitoring(OsInfoRetriever.java:234)[188:org.talend.monitoring.server:5.1.1]
        at org.talend.monitoring.jmx.server.OsInfoRetriever.<init>(OsInfoRetriever.java:303)[188:org.talend.monitoring.server:5.1.1]
        at org.talend.monitoring.jmx.server.OSInformationAgent.start(OSInformationAgent.java:105)[188:org.talend.monitoring.server:5.1.1]
        at org.talend.remote.jobserver.server.TalendJobServer.startMonitoringServer(TalendJobServer.java:223)[189:org.talend.remote.jobserver.server:5.1.1]
        at org.talend.remote.jobserver.server.TalendJobServer.startOnly(TalendJobServer.java:129)[189:org.talend.remote.jobserver.server:5.1.1]
        at org.talend.remote.jobserver.server.activator.Activator.updated(Activator.java:59)[189:org.talend.remote.jobserver.server:5.1.1]
        at org.apache.felix.cm.impl.ConfigurationManager$ManagedServiceUpdate.run(ConfigurationManager.java:1160)[5:org.apache.felix.configadmin:1.2.8]
        at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:104)[5:org.apache.felix.configadmin:1.2.8]
        at java.lang.Thread.run(Thread.java:662)[:1.6.0_33]

Offline

#2 2012-11-08 23:33:44

dneuman64
Member
20 posts

Re: [resolved] Error when starting Talend Runtime

this is the response I got from support, which solved my issue:

1) Stop the runtime
2) Download the zip file attached on your RH6.2 and unzip it
3)  Ask your system admin, to add to LD_LIBRARY_PATH or LDPATH (or both)  the path <hyperic-sigar-1.6.4_HOME>/sigar-bin/lib, where <hyperic-sigar-1.6.4_HOME> is the directory were you unziped the zip file
4) Restart the runtime and check

It is like the native library used by java to get the information on the server is missing, it seems to be know on Red Hat: http://stackoverflow.com/questions/1211 … rsionljava

Offline

#3 2012-11-09 09:01:43

ak_diallo
Member
1 post

Re: [resolved] Error when starting Talend Runtime

Thank you dneuman64 for sharing, i forgot to answer here too.

Regards,

Offline

#4 2012-11-09 09:03:35

adiallo
Talend Team


Re: [resolved] Error when starting Talend Runtime

Thank you dneuman64 for sharing, i forgot to answer here too.

Regards,


Abdoul Karim DIALLO

Offline

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy