You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2015-08-21 00:46:07

silpadowpati
Member
67 posts

silpadowpati said:

[resolved] Process and Trigger

Hi All,
I am working on Talend 561 for MDM with Bigdata edition.

I have a requirement in Talend MDM - "To update Timestamp with current date automatically whenever user tries to update a record in MDM UI manually".
I have tried with Before saving process to update a timestamp with current date.
I was able to get the value but it is not getting saved in MDM.

I created a job using   tMDMTriggerInput -->txmlmap --> tMDMTriggerOutput --> tlogrow --> tBufferOutput

xml structure in txmlmap
<exchange>
<report>
<Update>
<UserName>xxxxx</UserName>
<Source>genericUI</Source>
<TimeInMillis>1440113141834</TimeInMillis>
<RevisionID>null</RevisionID>
<DataCluster>xxxxx</DataCluster>
<DataModel>xxxxx</DataModel>
<Concept>T_AMA_STATE_CODE</Concept>
<Key>0555</Key>
<Item>
<path>CDE_STUS_CDE</path>
<oldValue>ACTIVE</oldValue>
<newValue>PENDING</newValue>
</Item>
<OperationType>UPDATE</OperationType>
</Update>
</report>
<item>
<T_AMA_STATE_CODE>
<ST_CDE>0555</ST_CDE>
<ST_DESC>DESCRIPTION MISSING</ST_DESC>
<CDE_STUS_CDE>PENDING</CDE_STUS_CDE>
<LAST_UPD_TSTMP></LAST_UPD_TSTMP>
</T_AMA_GENDER_CODE>
</item>
</exchange>


I was able to see the value for LAST_UPD_TSTMP(with currentdate) in mdm server console.
|MDM_Message                                                                                                                                                                    |<?xml version="1.0" encoding="UTF-8"?>
<exchange><report><Update><UserName>xxxxx</UserName><Source>genericUI</Source><TimeInMillis>1440113141834</TimeInMillis><RevisionID>null</RevisionID><DataCluster>xxxxx</DataCluster><DataModel>xxxxx</DataModel><Concept>T_AMA_STATE_CODE</Concept><Key>0555</Key><Item><path>CDE_STUS_CDE</path><oldValue>ACTIVE</oldValue><newValue>PENDING</newValue></Item><OperationType>UPDATE</OperationType></Update></report><item><T_AMA_STATE_CODE><ST_CDE>0555</ST_CDE><ST_DESC>DESCRIPTION MISSING</ST_DESC><CDE_STUS_CDE>PENDING</CDE_STUS_CDE><LAST_UPD_ID>xxxx</LAST_UPD_ID><LAST_UPD_TSTMP>2015-08-20</LAST_UPD_TSTMP></T_AMA_STATE_CODE></item></exchange>|

But when I try to save in MDM, It is giving following exception 
"The Validation process did not return the expected message, the record was not saved."


Can any one let me know the solution for this?


Thanks
Silpa

Offline

#2 2015-08-25 08:11:23

xdshi
Talend Team


xdshi said:

Re: [resolved] Process and Trigger

Hi Silpa,


We saw that your topic has been resolved by yourself. If it is fixed, would you mind sharing your solution with us?


Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#3 2016-11-25 08:46:32

Shrihari
Guest

Shrihari said:

Re: [resolved] Process and Trigger

Can you please tell me how did you add the output_item in the before save process.?

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy