You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2016-06-25 00:24:54

christopherhorn01845
Member
2 posts

christopherhorn01845 said:

error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator

I am running OS X 10.10.5; Have downloaded Open Studio w/ DQ. Running TOS_DQ-macosx-cocoa thros the following error: 
error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator

I had Java 8 installed and Open Studio asked me to install Java 6. I installed java 6 and got the above error. 

Terminal shows this Java version: 
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-468-11M4833)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-468, mixed mode)


More of the error i am getting below: 

!SESSION 2016-06-24 17:50:09.651 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US

!ENTRY org.eclipse.osgi 4 0 2016-06-24 17:50:10.188
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:171)
at 

Last edited by christopherhorn01845 (2016-06-25 00:30:22)

Offline

#2 2016-06-28 04:14:51

xdshi
Talend Team


xdshi said:

Re: error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator

Hi,

I had Java 8 installed and Open Studio asked me to install Java 6. I installed java 6 and got the above error.

Could you please indicate the DQ build version you are using? Talend 5.X?
Actually, this problem "Unsupported major.minor version 52.0." is usually caused by  "a higher JDK during compile time and lower JDK during runtime".

Did you compile your job using java 8 and run it using Java 6?
Have you tried to go to Window > Preferences > Installed JREs, selecting Edit and browsing for the appropriate JDK to see if it works?

Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#3 2016-06-28 13:39:39

christopherhorn01845
Member
2 posts

christopherhorn01845 said:

Re: error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator

I am not using Windows, as previously mentioned. 

I got it to work. 

Offline

#4 2016-09-20 21:29:36

Jappie11
Guest

Jappie11 said:

Re: error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator

Dear Christopherhorn01845,
I am on similar hardware and am experiencing the same issue: 

java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 52.0

Any chance of you sharing how you solved the problem?
Cheers JP

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy