You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2008-11-21 10:56:43

Kayo
Guest

Kayo said:

TOS-win32-x86 - "An error has occured. See the log file"

Tags: [error, JDK]

Hi,

I had this message (juste after the picture with the bridge) when I tried to launch TOS :

An error has occured. See the log file
C:\Program Files\TOS-Win32-R20205-V3.0.2\Configuration\XXXXX.log

Here is an extract of the log file :

!SESSION 2008-11-21 10:09:16.781 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.4.2_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_FR
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.equinox.app 0 0 2008-11-21 10:09:18.515
!MESSAGE Product org.talend.rcp.branding.tos.product could not be found.

!ENTRY org.eclipse.osgi 4 0 2008-11-21 10:09:18.578
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

!ENTRY org.eclipse.osgi 2 0 2008-11-21 10:09:18.890
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-11-21 10:09:18.890
!MESSAGE Bundle update@plugins/javax.mail_1.4.0.v200804091730.jar was not resolved.
!SUBENTRY 2 javax.mail 2 0 2008-11-21 10:09:18.890
!MESSAGE Missing imported package javax.activation_0.0.0.

Hope this is enough for you to help.

Thank you

#2 2008-11-21 11:00:33

shong
Talend Team


shong said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hello

eclipse.buildId=unknown
java.version=1.4.2_04

Talend requires JDK1.5 or greater.

Best regards

         shong


Email:shong@talend.com
Choose Talend, Enjoy Talend!
New & Event: Talend Help Center
Talend-->the global leader of open source data management and application integration solutions!

Offline

#3 2008-11-21 13:50:28

Kayo
Guest

Kayo said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Oops tongue !
It works now, thank you !

#4 2013-01-16 21:26:53

dasht
Guest

dasht said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

i have same error but my log file is some thing like this:

!SESSION 2013-01-13 02:43:13.785 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_10
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.osgi 2 0 2013-01-13 02:44:07.371
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:

...... many more

please help.

#5 2013-01-17 07:26:32

shong
Talend Team


shong said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi dasht

This topic is rather older, please report a new topic for your problem next time. For your problem, check that:
1. You have installed 64-bit JDK 1.6 or higher for your 64-bit system.
2. The installation path don't contains blank space.

Shong


Email:shong@talend.com
Choose Talend, Enjoy Talend!
New & Event: Talend Help Center
Talend-->the global leader of open source data management and application integration solutions!

Offline

#6 2013-01-18 22:48:39

dasht
Guest

dasht said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

well thanks i will take care of it next time but can you please tell me that how can we know that our window is of 32 or 64 bit ?????

#7 2013-01-21 04:04:28

shong
Talend Team


shong said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

dasht wrote:

well thanks i will take care of it next time but can you please tell me that how can we know that our window is of 32 or 64 bit ?????

Hi
Please read this article,How To Determine if Your Computer Is 32-Bit or 64-Bit, you can also find this information from the log file of Talend Studio:
ARCH=x86_64

It indicates your system is of 64 bit. To check your JDK information, you can simply execute this command in CMD:

java -version

Shong


Email:shong@talend.com
Choose Talend, Enjoy Talend!
New & Event: Talend Help Center
Talend-->the global leader of open source data management and application integration solutions!

Offline

#8 2013-01-22 19:25:44

dasht
Guest

dasht said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

ok thank you so much smile

#9 2015-07-22 16:29:40

shasthi
Guest

shasthi said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

!SESSION 2015-07-22 20:53:42.212 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_43
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_IN

!ENTRY org.eclipse.osgi 4 0 2015-07-22 20:53:42.480
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$000(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Unknown Source)
at org.eclipse.osgi.internal.hookregistry.HookRegistry.loadConfigurators(HookRegistry.java:185)
at org.eclipse.osgi.internal.hookregistry.HookRegistry.initialize(HookRegistry.java:106)
at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:73)
at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:295)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:231)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
at org.eclipse.equinox.launcher.Main.main(Main.java:1438)

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2015-07-22 20:53:49.925
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [314]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2015-07-22 20:53:49.930
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [316]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.designer.mapper 4 0 2015-07-22 20:53:49.949
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.designer.mapper [510]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.designer.runprocess 4 0 2015-07-22 20:53:49.969
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.designer.runprocess [519]
  Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
    -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
       org.talend.designer.runtime.visualization [521]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.designer.runtime.visualization.tools 4 0 2015-07-22 20:53:49.993
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.designer.runtime.visualization.tools [520]
  Unresolved requirement: Require-Bundle: org.talend.designer.runtime.visualization
    -> Bundle-SymbolicName: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runtime.visualization [521]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.designer.runtime.visualization 4 0 2015-07-22 20:53:49.998
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.designer.runtime.visualization [521]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.expressionbuilder 4 0 2015-07-22 20:53:50.004
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.expressionbuilder [530]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.rcp.branding.tos 4 0 2015-07-22 20:53:50.009
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.rcp.branding.tos [606]
  Unresolved requirement: Require-Bundle: org.talend.rcp
    -> Bundle-SymbolicName: org.talend.rcp; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.rcp [608]
         Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
           -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
              org.talend.designer.runprocess [519]
                Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
                  -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
                     org.talend.designer.runtime.visualization [521]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.rcp 4 0 2015-07-22 20:53:50.014
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.rcp [608]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.talend.repository.json 4 0 2015-07-22 20:53:50.018
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.talend.repository.json [618]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.app 0 0 2015-07-22 20:53:51.239
!MESSAGE Product org.talend.rcp.branding.tos.product could not be found.

!ENTRY org.talend.maven.resolver 4 0 2015-07-22 20:53:51.330
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Error starting module.
at org.eclipse.osgi.container.Module.doStart(Module.java:580)
at org.eclipse.osgi.container.Module.start(Module.java:439)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
Caused by: java.lang.UnsupportedClassVersionError: org/talend/maven/resolver/Activator : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.defineClass(ModuleClassLoader.java:285)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.defineClass(ClasspathManager.java:632)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassImpl(ClasspathManager.java:588)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClassImpl(ClasspathManager.java:540)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:527)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:324)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:320)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:345)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:337)
at org.eclipse.osgi.internal.framework.BundleContextImpl.loadBundleActivator(BundleContextImpl.java:754)
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:706)
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:936)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:319)
at org.eclipse.osgi.container.Module.doStart(Module.java:571)
... 8 more
Root exception:
java.lang.UnsupportedClassVersionError: org/talend/maven/resolver/Activator : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(Unknown Source)
at java.lang.ClassLoader.defineClass(Unknown Source)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.defineClass(ModuleClassLoader.java:285)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.defineClass(ClasspathManager.java:632)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findClassImpl(ClasspathManager.java:588)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClassImpl(ClasspathManager.java:540)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:527)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:324)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:320)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:345)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:337)
at org.eclipse.osgi.internal.framework.BundleContextImpl.loadBundleActivator(BundleContextImpl.java:754)
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:706)
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:936)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:319)
at org.eclipse.osgi.container.Module.doStart(Module.java:571)
at org.eclipse.osgi.container.Module.start(Module.java:439)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2015-07-22 20:53:51.688
!MESSAGE Bundle org.talend.maven.resolver_6.0.0.20150702_1326 [6] is not active.

!ENTRY org.eclipse.core.resources.win32.x86 2 0 2015-07-22 20:53:51.794
!MESSAGE Could not resolve module: org.eclipse.core.resources.win32.x86 [104]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.talend.designer.mapper.nl 2 0 2015-07-22 20:53:51.798
!MESSAGE Could not resolve module: org.talend.designer.mapper.nl [509]
  Unresolved requirement: Fragment-Host: org.talend.designer.mapper
    -> Bundle-SymbolicName: org.talend.designer.mapper; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.mapper [510]
         Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
           -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
              org.talend.designer.runprocess [519]
                Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
                  -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
                     org.talend.designer.runtime.visualization [521]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.ui.cocoa 2 0 2015-07-22 20:53:51.801
!MESSAGE Could not resolve module: org.eclipse.ui.cocoa [420]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.ws=cocoa)"


!ENTRY org.eclipse.jdt.annotation 2 0 2015-07-22 20:53:51.805
!MESSAGE Could not resolve module: org.eclipse.jdt.annotation [297]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"


!ENTRY org.eclipse.core.filesystem.linux.ppc64 2 0 2015-07-22 20:53:51.810
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.linux.ppc64 [89]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=ppc64))"


!ENTRY org.eclipse.core.filesystem.java7 2 0 2015-07-22 20:53:51.815
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.java7 [87]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  Unresolved requirement: Fragment-Host: org.eclipse.core.filesystem; bundle-version="[1.4.100,2.0.0)"


!ENTRY org.eclipse.swt.gtk.linux.x86 2 0 2015-07-22 20:53:51.818
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.x86 [402]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.talend.designer.runtime.visualization 2 0 2015-07-22 20:53:51.822
!MESSAGE Could not resolve module: org.talend.designer.runtime.visualization [521]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.talend.repository.json 2 0 2015-07-22 20:53:51.825
!MESSAGE Could not resolve module: org.talend.repository.json [618]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.equinox.security.macosx 2 0 2015-07-22 20:53:51.829
!MESSAGE Could not resolve module: org.eclipse.equinox.security.macosx [242]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=x86_64)(osgi.arch=ppc)) )"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.x86 2 0 2015-07-22 20:53:51.832
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.x86 [202]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.eclipse.core.filesystem.aix.ppc64 2 0 2015-07-22 20:53:51.836
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.aix.ppc64 [84]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=aix) (osgi.arch=ppc64))"


!ENTRY org.eclipse.core.filesystem.hpux.ia64 2 0 2015-07-22 20:53:51.841
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.hpux.ia64 [86]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=hpux) (osgi.arch=ia64))"


!ENTRY org.talend.designer.mapper 2 0 2015-07-22 20:53:51.845
!MESSAGE Could not resolve module: org.talend.designer.mapper [510]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.s390x 2 0 2015-07-22 20:53:51.850
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.s390x [200]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390x))"


!ENTRY org.eclipse.core.filesystem.solaris.sparc 2 0 2015-07-22 20:53:51.860
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.solaris.sparc [94]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=solaris) (osgi.arch=sparc))"


!ENTRY org.eclipse.swt.gtk.solaris.x86 2 0 2015-07-22 20:53:51.865
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.solaris.x86 [408]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=x86))"


!ENTRY org.talend.rcp.branding.tos 2 0 2015-07-22 20:53:51.869
!MESSAGE Could not resolve module: org.talend.rcp.branding.tos [606]
  Unresolved requirement: Require-Bundle: org.talend.rcp
    -> Bundle-SymbolicName: org.talend.rcp; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.rcp [608]
         Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
           -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
              org.talend.designer.runprocess [519]
                Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
                  -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
                     org.talend.designer.runtime.visualization [521]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.ppc64 2 0 2015-07-22 20:53:51.873
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.ppc64 [198]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"


!ENTRY org.eclipse.swt.gtk.aix.ppc 2 0 2015-07-22 20:53:51.876
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.aix.ppc [388]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc))"


!ENTRY org.eclipse.equinox.launcher.gtk.aix.ppc 2 0 2015-07-22 20:53:51.879
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.aix.ppc [195]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc))"


!ENTRY org.eclipse.core.filesystem.linux.x86_64 2 0 2015-07-22 20:53:51.883
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.linux.x86_64 [92]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=x86_64))"


!ENTRY org.talend.designer.runprocess 2 0 2015-07-22 20:53:51.886
!MESSAGE Could not resolve module: org.talend.designer.runprocess [519]
  Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
    -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
       org.talend.designer.runtime.visualization [521]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.talend.expressionbuilder 2 0 2015-07-22 20:53:51.889
!MESSAGE Could not resolve module: org.talend.expressionbuilder [530]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.e4.ui.workbench.renderers.swt.cocoa 2 0 2015-07-22 20:53:51.892
!MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt.cocoa [128]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.ws=cocoa)"


!ENTRY org.eclipse.equinox.launcher.gtk.hpux.ia64 2 0 2015-07-22 20:53:51.895
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.hpux.ia64 [196]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=hpux) (osgi.arch=ia64))"


!ENTRY org.eclipse.jdt.launching.macosx 2 0 2015-07-22 20:53:51.898
!MESSAGE Could not resolve module: org.eclipse.jdt.launching.macosx [314]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"


!ENTRY org.eclipse.equinox.launcher.gtk.solaris.x86 2 0 2015-07-22 20:53:51.901
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.solaris.x86 [205]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=x86))"


!ENTRY org.eclipse.equinox.launcher.cocoa.macosx.x86_64 2 0 2015-07-22 20:53:51.904
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.cocoa.macosx.x86_64 [192]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"


!ENTRY org.eclipse.core.filesystem.macosx 2 0 2015-07-22 20:53:51.907
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.macosx [93]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=macosx) (|(osgi.arch=x86) (osgi.arch=ppc) (osgi.arch=x86_64)))"


!ENTRY org.eclipse.core.net.linux.x86 2 0 2015-07-22 20:53:51.910
!MESSAGE Could not resolve module: org.eclipse.core.net.linux.x86 [99]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.eclipse.swt.gtk.linux.ppc64 2 0 2015-07-22 20:53:51.913
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc64 [395]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"


!ENTRY org.eclipse.equinox.launcher.gtk.solaris.sparc 2 0 2015-07-22 20:53:51.916
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.solaris.sparc [204]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"


!ENTRY org.eclipse.swt.gtk.linux.ppc64le 2 0 2015-07-22 20:53:51.919
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc64le [394]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64le))"


!ENTRY org.eclipse.equinox.launcher.win32.win32.x86 2 0 2015-07-22 20:53:51.922
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.win32.win32.x86 [206]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.talend.expressionbuilder.nl 2 0 2015-07-22 20:53:51.925
!MESSAGE Could not resolve module: org.talend.expressionbuilder.nl [529]
  Unresolved requirement: Fragment-Host: org.talend.expressionbuilder
    -> Bundle-SymbolicName: org.talend.expressionbuilder; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.expressionbuilder [530]
         Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
           -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
              org.talend.designer.runprocess [519]
                Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
                  -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
                     org.talend.designer.runtime.visualization [521]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.talend.repository.json.nl 2 0 2015-07-22 20:53:51.927
!MESSAGE Could not resolve module: org.talend.repository.json.nl [617]
  Unresolved requirement: Fragment-Host: org.talend.repository.json
    -> Bundle-SymbolicName: org.talend.repository.json; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.repository.json [618]
         Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
           -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
              org.talend.designer.runprocess [519]
                Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
                  -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
                     org.talend.designer.runtime.visualization [521]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.equinox.launcher.cocoa.macosx 2 0 2015-07-22 20:53:51.930
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.cocoa.macosx [193]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"


!ENTRY org.talend.rcp 2 0 2015-07-22 20:53:51.933
!MESSAGE Could not resolve module: org.talend.rcp [608]
  Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.core.filesystem.linux.x86 2 0 2015-07-22 20:53:51.936
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.linux.x86 [91]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=x86))"


!ENTRY org.eclipse.core.filesystem.win32.x86 2 0 2015-07-22 20:53:51.939
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.win32.x86 [95]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.core.net.win32.x86 2 0 2015-07-22 20:53:51.942
!MESSAGE Could not resolve module: org.eclipse.core.net.win32.x86 [101]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.talend.designer.maven.job.nl 2 0 2015-07-22 20:53:51.945
!MESSAGE Could not resolve module: org.talend.designer.maven.job.nl [511]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
  Unresolved requirement: Fragment-Host: org.talend.designer.maven.job


!ENTRY org.eclipse.swt.gtk.linux.x86_64 2 0 2015-07-22 20:53:51.948
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.x86_64 [404]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))"


!ENTRY org.talend.rcp.nl 2 0 2015-07-22 20:53:51.951
!MESSAGE Could not resolve module: org.talend.rcp.nl [607]
  Unresolved requirement: Fragment-Host: org.talend.rcp
    -> Bundle-SymbolicName: org.talend.rcp; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.rcp [608]
         Unresolved requirement: Require-Bundle: org.talend.designer.runprocess
           -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
              org.talend.designer.runprocess [519]
                Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
                  -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
                     org.talend.designer.runtime.visualization [521]
                       Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.core.filesystem.aix.ppc 2 0 2015-07-22 20:53:51.954
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.aix.ppc [85]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=aix) (osgi.arch=ppc))"


!ENTRY org.eclipse.swt.gtk.hpux.ia64 2 0 2015-07-22 20:53:51.957
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.hpux.ia64 [390]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=hpux) (osgi.arch=ia64))"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.x86_64 2 0 2015-07-22 20:53:51.960
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.x86_64 [203]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86_64))"


!ENTRY org.eclipse.jdt.launching.ui.macosx 2 0 2015-07-22 20:53:51.963
!MESSAGE Could not resolve module: org.eclipse.jdt.launching.ui.macosx [316]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"


!ENTRY org.eclipse.core.net.linux.x86_64 2 0 2015-07-22 20:53:51.966
!MESSAGE Could not resolve module: org.eclipse.core.net.linux.x86_64 [100]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=x86_64))"


!ENTRY org.eclipse.swt.gtk.solaris.sparc 2 0 2015-07-22 20:53:51.969
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.solaris.sparc [406]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=solaris) (osgi.arch=sparc))"


!ENTRY org.eclipse.swt.gtk.aix.ppc64 2 0 2015-07-22 20:53:51.972
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.aix.ppc64 [387]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc64))"


!ENTRY org.eclipse.equinox.security.win32.x86 2 0 2015-07-22 20:53:51.975
!MESSAGE Could not resolve module: org.eclipse.equinox.security.win32.x86 [245]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.swt.cocoa.macosx 2 0 2015-07-22 20:53:51.977
!MESSAGE Could not resolve module: org.eclipse.swt.cocoa.macosx [384]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (|(osgi.arch=x86)(osgi.arch=ppc)) )"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.s390 2 0 2015-07-22 20:53:51.980
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.s390 [201]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390))"


!ENTRY org.eclipse.equinox.launcher.gtk.aix.ppc64 2 0 2015-07-22 20:53:51.984
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.aix.ppc64 [194]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=aix) (osgi.arch=ppc64))"


!ENTRY org.eclipse.swt.gtk.linux.s390x 2 0 2015-07-22 20:53:51.987
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.s390x [399]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390x))"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.ppc 2 0 2015-07-22 20:53:51.990
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.ppc [199]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc))"


!ENTRY org.eclipse.swt.cocoa.macosx.x86_64 2 0 2015-07-22 20:53:51.993
!MESSAGE Could not resolve module: org.eclipse.swt.cocoa.macosx.x86_64 [383]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"


!ENTRY org.eclipse.swt.win32.win32.x86 2 0 2015-07-22 20:53:51.995
!MESSAGE Could not resolve module: org.eclipse.swt.win32.win32.x86 [410]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"


!ENTRY org.eclipse.core.filesystem.linux.ppc 2 0 2015-07-22 20:53:51.999
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.linux.ppc [90]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=ppc))"


!ENTRY org.eclipse.equinox.launcher.gtk.linux.ppc64le 2 0 2015-07-22 20:53:52.002
!MESSAGE Could not resolve module: org.eclipse.equinox.launcher.gtk.linux.ppc64le [197]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64le))"


!ENTRY org.eclipse.core.filesystem.linux.ppc64le 2 0 2015-07-22 20:53:52.005
!MESSAGE Could not resolve module: org.eclipse.core.filesystem.linux.ppc64le [88]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.os=linux) (osgi.arch=ppc64le))"


!ENTRY org.talend.designer.runprocess.nl 2 0 2015-07-22 20:53:52.008
!MESSAGE Could not resolve module: org.talend.designer.runprocess.nl [518]
  Unresolved requirement: Fragment-Host: org.talend.designer.runprocess
    -> Bundle-SymbolicName: org.talend.designer.runprocess; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runprocess [519]
         Unresolved requirement: Import-Package: org.talend.designer.runtime.visualization
           -> Export-Package: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; bundle-symbolic-name="org.talend.designer.runtime.visualization"; version="0.0.0"
              org.talend.designer.runtime.visualization [521]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.talend.designer.runtime.visualization.tools 2 0 2015-07-22 20:53:52.013
!MESSAGE Could not resolve module: org.talend.designer.runtime.visualization.tools [520]
  Unresolved requirement: Require-Bundle: org.talend.designer.runtime.visualization
    -> Bundle-SymbolicName: org.talend.designer.runtime.visualization; bundle-version="6.0.0.20150702_1326"; singleton:="true"
       org.talend.designer.runtime.visualization [521]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"


!ENTRY org.eclipse.swt.gtk.linux.s390 2 0 2015-07-22 20:53:52.020
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.s390 [400]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=s390))"


!ENTRY org.eclipse.swt.gtk.linux.ppc 2 0 2015-07-22 20:53:52.025
!MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc [396]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc))"


!ENTRY org.eclipse.osgi 4 0 2015-07-22 20:53:52.041
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
at org.eclipse.equinox.launcher.Main.main(Main.java:1438)

#10 2015-07-22 17:26:12

esabot
Talend Team


esabot said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Change your Java version. Just read the previous messages on this thread. The recommended version of Java is now 8 with v6.0 as java 1.7 is end of life.
Also an introduction sentence and some greetings would make it nicer... smile

HTH
Elisa


Follow Talend on Twitter, Linkedin and Facebook.

Offline

#11 2015-08-19 15:56:47

chris.aldous
Member
31 posts

chris.aldous said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi Elisa, 
Apologies if there are some newer threads regarding this topic - if so i'm happy to redirect towards them.
A client of mine has experienced the same issue. I have had them send through the log files as the error was unexpected and completely random (to my knowledge!).
I was hoping you could help me make heads or tails of this...

!SESSION 2015-07-15 13:55:06.368 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB
Command-line arguments:  -os win32 -ws win32 -arch x86

This is a continuation of log file C:\Talend\TOS_DI-Win32-20150702_1326-V6.0.0\workspace\.metadata\.bak_6.log
Created Time: 2015-07-15 14:01:02.812

!ENTRY org.talend.platform.logging 2 0 2015-07-15 14:01:02.822
!MESSAGE 2015-07-15 14:01:02,812 WARN  org.ops4j.pax.url.mvn.internal.AetherBasedResolver  - Error resolving artifactorg.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT:Could not find artifact org.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT

!STACK 0
shaded.org.eclipse.aether.resolution.ArtifactResolutionException: Could not find artifact org.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:444)
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifacts(DefaultArtifactResolver.java:246)
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolveArtifact(DefaultArtifactResolver.java:223)
at shaded.org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveArtifact(DefaultRepositorySystem.java:294)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:576)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:531)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:506)
at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve(AetherBasedResolver.java:481)
at org.talend.core.model.general.ModuleNeeded.getStatus(ModuleNeeded.java:246)
at org.talend.librariesmanager.model.ModulesNeededProvider.getUnistalledModulesNeeded(ModulesNeededProvider.java:796)
at org.talend.updates.runtime.engine.factory.PluginOptionalMissingJarsExtraUpdatesFactory.retrieveUninstalledExtraFeatures(PluginOptionalMissingJarsExtraUpdatesFactory.java:53)
at org.talend.updates.runtime.engine.ExtraFeaturesUpdatesFactory.retrieveUninstalledExtraFeatures(ExtraFeaturesUpdatesFactory.java:49)
at org.talend.updates.runtime.ui.CheckExtraFeaturesToInstallJob.run(CheckExtraFeaturesToInstallJob.java:67)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: shaded.org.eclipse.aether.transfer.ArtifactNotFoundException: Could not find artifact org.talend.libraries:mysql-connector-java-5.1.30-bin:jar:6.0.0-SNAPSHOT
at shaded.org.eclipse.aether.internal.impl.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:434)
... 13 more

Thanks in advance for your help.

Cheers,
Chris

Offline

#12 2015-08-28 22:10:31

mikich
Member
4 posts

mikich said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi,

It looks like I have similar (common) issue, here is my error from the log file:

eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US

!ENTRY org.eclipse.osgi 4 0 2015-08-28 15:59:44.430
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 51.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:171)
	at org.eclipse.osgi.internal.hookregistry.HookRegistry.loadConfigurators(HookRegistry.java:185)
	at org.eclipse.osgi.internal.hookregistry.HookRegistry.initialize(HookRegistry.java:106)
	at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:73)
	at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:295)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:231)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

Thanks for help

Offline

#13 2015-08-31 05:00:05

xdshi
Talend Team


xdshi said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi mikich,

What's the build version you are using? What's your OS
Have you already checked document about:TalendHelpCenter:Compatible+Platforms+and+Java+environments to see if you are on a compatible platform?

Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#14 2015-09-01 21:07:38

mikich
Member
4 posts

mikich said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

xdshi wrote:

Hi mikich,

What's the build version you are using? What's your OS
Have you already checked document about:TalendHelpCenter:Compatible+Platforms+and+Java+environments to see if you are on a compatible platform?

Best regards
Sabrina

Dear xdshi,

Thank you for trying to help!
All information you asking is in the log I've provided in previous message, anyway here is what you asking for:
I think the problem was - luck of JAVA_HOME defined in my environment, so I solved this problem  smile


java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US


Now I have another problem, based on your experience, what it could be?

Here is the error msg from the pop-up error window:

java.lang.NullPointerException
	at org.talend.designer.codegen.JavaRoutineSynchronizer.doSyncRoutine(JavaRoutineSynchronizer.java:145)
	at org.talend.designer.codegen.AbstractRoutineSynchronizer.syncRoutine(AbstractRoutineSynchronizer.java:169)
	at org.talend.designer.codegen.JavaRoutineSynchronizer.syncRoutineItems(JavaRoutineSynchronizer.java:103)
	at org.talend.designer.codegen.JavaRoutineSynchronizer.syncAllRoutinesForLogOn(JavaRoutineSynchronizer.java:82)
	at org.talend.core.CoreService.syncAllRoutines(CoreService.java:281)
	at org.talend.core.repository.model.ProxyRepositoryFactory.logOnProject(ProxyRepositoryFactory.java:1826)
	at org.talend.repository.ui.login.LoginHelper$2.run(LoginHelper.java:404)
	at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)

Offline

#15 2016-10-28 03:21:08

guravaiah
Guest

guravaiah said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi Talend Support Team,
please help me at the earliest.thank you!
my system details are as below:
window 10 64 bit and added JAVA_HOME  variale aslo
C:\Users\kayam>java -version
java version "1.7.0_79"
Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)
while installing Talend 6.2.1  getting below error.
!SESSION 2016-10-27 21:46:28.337 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_79
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
!ENTRY org.eclipse.osgi 4 0 2016-10-27 21:46:29.299
!MESSAGE error loading hook: org.talend.osgi.configurator.JarLoaderConfigurator
!STACK 0
java.lang.UnsupportedClassVersionError: org/talend/osgi/configurator/JarLoaderConfigurator : Unsupported major.minor version 52.0

#16 2016-10-28 07:56:30

xdshi
Talend Team


xdshi said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi guravaiah,
Are you usind talend 6.x product? Java 8 is currently the recommended Java version for all Talend products and modules since v6.0. 
Could you please try to use jdk 1.8 instead to see if it works?
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#17 2016-12-19 13:49:36

oussama16
Guest

oussama16 said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hello everybody

Im actually facing the same problem here
I have an ubuntu machine 14.04LTS - 64bit
I did download TOS_DI-20161026_1219-V6.3.0 and cpoied it to /usr/local  also extracted xulrunner-41.0b9.en-US.linux-x86_64.tar.bz2 to /usr/local/lib
I updated the file TOS_DI-linux-gtk-x86_64.ini as follow

-vmargs
-Xms512m
-Xmx1536m
-Dfile.encoding=UTF-8
-Dosgi.requiredJavaVersion=1.8
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/local/lib/xulrunner

and created a bash file to start Talend as follow

#!/bin/sh
     export GDK_NATIVE_WINDOWS=1
     '/usr/local/TOS_DI-20161026_1219-V6.3.0/TOS_DI-linux-gtk-x86_64'

now when I run my bash file, I have this error An Error has occured see the log file                                                            
and here is my log file

!SESSION 2016-12-19 12:41:15.925 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_111
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=fr_FR
Command-line arguments:  -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.jdt.launching.macosx 4 0 2016-12-19 12:41:17.019
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.macosx [294]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

        at org.eclipse.osgi.container.Module.start(Module.java:434)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jdt.launching.ui.macosx 4 0 2016-12-19 12:41:17.075
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jdt.launching.ui.macosx [475]
  Unresolved requirement: Require-Capability: eclipse.platform; filter:="(osgi.os=macosx)"

        at org.eclipse.osgi.container.Module.start(Module.java:434)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

#18 2016-12-20 10:25:45

xdshi
Talend Team


xdshi said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi oussama16,
Are you installing the TOS on VM?
If so, please don't directly copy the unzipped file from physical machine to VM, which will cause some files broken during copying processing. If you are using the VM, please copying the zip and then unzip from VM.
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#19 2016-12-22 09:43:00

xdshi
Talend Team


xdshi said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi oussama16,
Any update for your issue?
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#20 2017-03-28 01:57:16

selma24
Guest

selma24 said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

i have same error but my log file is some thing like this:
!SESSION 2017-03-28 00:25:21.337 -----------------------------------------------
eclipse.buildId=4.6.3.M20170301-0400
java.version=9-ea
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product


!ENTRY org.eclipse.osgi 4 0 2017-03-28 00:25:38.684
!MESSAGE Application error
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:386)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:294)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:490)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:504)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:203)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:632)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:151)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:375)
... 23 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.1.v20160712-0927
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
... 25 more


!ENTRY org.eclipse.e4.ui.workbench 4 0 2017-03-28 00:25:38.778
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:426)
at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:154)
at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:176)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:106)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:139)
at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:903)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:156)
at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
at org.eclipse.osgi.container.Module.doStop(Module.java:634)
at org.eclipse.osgi.container.Module.stop(Module.java:498)
at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.1.v20160712-0927
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
... 21 more
!SESSION 2017-03-28 00:34:08.595 -----------------------------------------------
eclipse.buildId=4.6.3.M20170301-0400
java.version=9-ea
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=fr_FR
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.jee.product


!ENTRY org.eclipse.osgi 4 0 2017-03-28 00:34:16.041
!MESSAGE Application error
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:386)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:294)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:490)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:504)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:203)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:632)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:151)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:375)
... 23 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.1.v20160712-0927
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
... 25 more


!ENTRY org.eclipse.e4.ui.workbench 4 0 2017-03-28 00:34:16.360
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:426)
at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:154)
at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:176)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:106)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:139)
at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:903)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:156)
at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
at org.eclipse.osgi.container.Module.doStop(Module.java:634)
at org.eclipse.osgi.container.Module.stop(Module.java:498)
at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
at java.base/java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.1.v20160712-0927
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:410)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
at java.base/java.lang.ClassLoader.loadClass(Unknown Source)

... 21 more

#21 2017-03-28 14:04:48

xdshi
Talend Team


xdshi said:

Re: TOS-win32-x86 - "An error has occured. See the log file"

Hi selma24,
What's build version you are using?
So far, Talend Studio requires oracle JDK 1.7(V 5.6) or higher(since V 6.0).

Please take a look at document about:TalendHelpCenter:Java.
Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy