You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2013-12-05 12:54:40

Steve.ward
Member
3 posts

Steve.ward said:

Job fails when run as a batch, yet works fine when run from Talend

Tags: [database, mssql]

Hi

I have created a simple Talend DI job which extracts data from one data source and inserts into a SQL database into a number of tables.  I need the job to run on a daily schedule, so have exported the job scripts and am able to run the windows batch job created.

When the job is running from the batch file, it stops half way through having updated some tables and not others.  If I run the job from within Talend it completes successfully every time.

Any ideas why this would be happening, or how I would diagnose the issue?

I am running an old version of Talend 4.1.0, happy to upgrade of this would help, so long as I can import the job into the new version.

Many thanks

Steve

Last edited by Steve.ward (2013-12-05 12:55:50)

Offline

#2 2013-12-05 13:32:17

xdshi
Talend Team


xdshi said:

Re: Job fails when run as a batch, yet works fine when run from Talend

Hi,

Is there any dependency in your job? Did you follow up online document TalendHelpCenter:How+to+build+Jobs to export your job as .bat file?

Best regards
Sabrina


What we can do is to make sure that Talend will be your best choice!

Offline

#3 2013-12-05 13:41:05

Steve.ward
Member
3 posts

Steve.ward said:

Re: Job fails when run as a batch, yet works fine when run from Talend

Hi Sabrina

I fall over on the The first part of the documentation you refer to which states:

before building your Job, go to Window > Preferences, select Talend > Import/Export, and then select the Add classpath Jar, when export job.

I don't seem to have this option, the only options I see when navigating to Import/Export are:
Import / Export > Use recent file name to save, When export job script
Shell Setting> %GENERATED_TOS_CALL%
Spagic Server> Enable / Disable Deploy on Spagic
SpagoBi> Enable/Disable Deploy on SpagoBi

Continuing through the documentation, I also don't have the option for the next step of right click the job and select "build job"

I am running 4.1.0, are there separate instructions for this version, do I need to upgrade, can I import projects / jobs from 4.1.0 if I do need to upgrade?

Thanks!
Steve

Last edited by Steve.ward (2013-12-05 13:48:59)

Offline

#4 2017-04-07 21:00:52

florinesl3
Guest

florinesl3 said:

Re: Job fails when run as a batch, yet works fine when run from Talend

My novel number

  ireland top date asian women free free sexy singles bbw sites online chatting with women

#5 2017-04-08 07:56:14

corrinewe2
Guest

corrinewe2 said:

Re: Job fails when run as a batch, yet works fine when run from Talend

Check my new engagement
photos secxi wallpaper video downlkad one plus buy free movies 9apps mobile software

android pay as you go download games online for free app store apps best smartphones reviews developer android apps

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy