You are not logged in.

Unanswered posts

Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at We look forward to hearing from you there!

#1 2010-03-24 16:02:30

29 posts

bronius said:

General errors reading files on Vista: RESOLVED (sort of)

To anyone who's having issues on Vista, run as Administrator.  Anyone have a better solution?

Having not used TOS for many months, I came back and installed on a Vista machine.  Everything _appeared_ ok, but I couldn't read an Excel 2007 file.  So I tried an Excel 97 format.  Then I tried a csv and even single column text file: I think it's Vista's file permission restrictions.

Launching Talend Open Studio as administrator (In Vista, right-click the TOS icon, select Run As Administrator) launched and showed me what looked like a fresh repository and everything.. Ok, no big deal since my last ones didn't work smile.  I tried a simple file read, and it worked the first time.

Hope this helps!

oh, here is a sample, confusing error message I used to get when running on Vista but not as administrator:

Exception in thread "main" java.lang.NoClassDefFoundError: com/csvreader/CsvWriter
	at remove_bounces_for_herrick.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput.tFileInputDelimitedProcess(
	at remove_bounces_for_herrick.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput.runJobInTOS(
	at remove_bounces_for_herrick.shadowfileinputtodelimitedoutput_0_1.ShadowFileInputToDelimitedOutput.main(
Caused by: java.lang.ClassNotFoundException: com.csvreader.CsvWriter
	at$ Source)
	at Method)
	at Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	... 3 more

Preview error. Some settings must be changed.
Note: Preview errors are generally due to a wrong encoding setting.
org.talend.designer.runprocess.shadow.ShadowFilePreview.preview(Unknown Source)
org.talend.repository.ui.utils.ShadowProcessHelper.getCsvArray(Unknown Source)
org.talend.designer.filemultischemas.ui.preview.MultiSchemasUIThreadProcessor.nonUIProcessInThread(Unknown Source)
org.talend.commons.ui.swt.thread.SWTUIThreadProcessor$ Source)

Another error I got was something like "Missing class error". Hope this helps.


#2 2010-03-25 03:36:34

Talend Team

shong said:

Re: General errors reading files on Vista: RESOLVED (sort of)

Thanks for your solution!

Best regards
Choose Talend, Enjoy Talend!
New & Event: Talend Help Center
Talend-->the global leader of open source data management and application integration solutions!


#3 2017-04-03 13:27:54

26 posts

feroz_syed said:

Re: General errors reading files on Vista: RESOLVED (sort of)

Hi Team,
I am getting the same error while running the job on TAC and the is job running fine in Studio.
Thanks in advance


Board footer

Talend Contributor Agreement - Talend Website Privacy Policy