You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2006-11-21 15:10:06

Paf
Guest

Paf said:

Oracle Extraction

Hello,

In a very simple test, I try to extract datas from a Oracle database.
Using a DBInput_1 object, properties are correctly filled,
When executing it, talend send me a popup with this message "The entrance point of Perl_Glockhook_ptr procedure is untraceable in the bibliotheque one of connections dynamics perl58.dll"

In the logs output :
_________________

Starting job MyFirstJob at 14:49 21/11/2006.

  Copyright (c) 2005-2006, Talend SA

  This source code has been automatically generated by talend
  OpenStudio / ProcessDesigner (CodeGenerator version 1.0.0.20061004-1934-V1).
  You can find more information about talend products at www.talend.com.
  You may distribute this code under the terms of either the GNU General
  Public License or under the Artistic License just like Perl itself.

tsInfo>  Running process with context: C:\TOS-Win32-20061004-1934-V1\workspace\.Perl\TEST.process_MyFirstJob_Default.pl (./tUser/parameters_C:\TOS-Win32-20061004-1934-V1\workspace\.Perl\TEST.process_MyFirstJob_Default.pl.pl)

install_driver(Oracle) failed: Can't load 'C:/Perl/site/lib/auto/DBD/Oracle/Oracle.dll' for module DBD::Oracle: load_file:La procédure spécifiée est introuvable at C:/Perl/lib/DynaLoader.pm line 229.
at (eval 3) line 3
Compilation failed in require at (eval 3) line 3.
Perhaps a required shared library or dll isn't installed where expected
at C:\TOS-Win32-20061004-1934-V1\workspace\.Perl\TEST.process_MyFirstJob.pl line 163
Job MyFirstJob ended at 14:50 21/11/2006. [exit code=255]

_________________


For information all Perl librairies recommended ine the pdf file have been installed : DBI, DBD-Oracle, etc...

What can I do please ?

#2 2006-11-21 15:35:13

Paf
Guest

Paf said:

Re: Oracle Extraction

My DBD-Oracle is version 1.17, but the talend Modules view say it is not installed.....
What's wrong with that, seems to be the same problem ?

#3 2006-11-21 16:13:33

Paf
Guest

Paf said:

Re: Oracle Extraction

Resolved with installing ActivePerl version 3.8.8.

#4 2006-11-21 17:51:04

cantoine
Talend Team


cantoine said:

Re: Oracle Extraction

Hello,   

It is possible that the "Modules View" show errors even if you have just installed a module. 
Restart the Talend product and verify if modules are successful installed.   

For Oracle, my version of DBD:Oracle is 1.17, it's all right.   

On what OS are you running?

Have you installed locally an Oracle client on your platform ? 
Verify if your Client works normally and test connection to your Database

Regards.

PS : don't forgot to checkyour tnsnames.ora file

Offline

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy