You are not logged in.

Unanswered posts



Important! This site has been replaced. All content here is read-only. Please visit our brand-new community at https://community.talend.com/. We look forward to hearing from you there!



#1 2007-11-08 10:37:47

cbredel
Member
3 posts

cbredel said:

Erreur au démarrage de SDI

Bonjour,

Je suis sous windows XP 32 bits avec un java 1.6.0_02.

Au démarrage de SDI (la version disponible ce matin) , j'arrive à la fenêtre de connection. Je crée ma connexion. Je crée un projet java. Puis après avoir cliqué sur Ok, j'ai le message d'erreur m'indiquant :  java.lang.NoClassDefFoundError cannot be cast to java.lang.Exception

Sinon, j'ai une installation de Talend (TOS_ALL-v5798-v2.2RC1) qui fonctionne correctement sur mon poste.

Pouvez-vous m'aider à démarrer SDI ?

Merci d'avance

Christophe




Pour info, dans le log, j'ai les infos suivantes :
java.lang.ClassCastException: java.lang.NoClassDefFoundError cannot be cast to java.lang.Exception
    at org.talend.repository.ui.login.LoginDialog.logIn(Unknown Source)
    at org.talend.repository.ui.login.LoginDialog.okPressed(Unknown Source)
    at org.eclipse.jface.dialogs.Dialog.buttonPressed(Dialog.java:464)
    at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:616)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:227)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3682)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3293)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:820)
    at org.eclipse.jface.window.Window.open(Window.java:796)
    at org.talend.rcp.intro.Application.logUserOnProject(Unknown Source)
    at org.talend.rcp.intro.Application.start(Unknown Source)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:153)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:504)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:443)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1169)

Offline

#2 2007-11-09 08:11:20

shong
Talend Team


shong said:

Re: Erreur au démarrage de SDI

Hi
This forum is meant to be international.
If you want to get help from members of the Talend team and from many non-French speaking users, who may have experienced the same issue as you, please make the effort to post in English.

Best regards

         shong


Email:shong@talend.com
Choose Talend, Enjoy Talend!
New & Event: Talend Help Center
Talend-->the global leader of open source data management and application integration solutions!

Offline

#3 2007-11-09 10:19:37

elemoine
Member
4 posts

elemoine said:

Re: Erreur au démarrage de SDI

Translating Christophe's message:

Hi

I use windows XP 32 bits with java 1.6.0_02.

At SDI startup, I get the connection window. I create a connection. I create a java project. Then, after clicking Ok, I get the error message saying java.lang.NoClassDefFoundError cannot be cast to java.lang.Exception.

I have TOS_ALL-v5798-v2.2RC1 that functions properly on my setup.

Can you help me starting SDI?

Thanks

Christophe

java.lang.ClassCastException: java.lang.NoClassDefFoundError cannot be cast to java.lang.Exception
    at org.talend.repository.ui.login.LoginDialog.logIn(Unknown Source)
    at org.talend.repository.ui.login.LoginDialog.okPressed(Unknown Source)
    at org.eclipse.jface.dialogs.Dialog.buttonPressed(Dialog.java:464)
    at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:616)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:227)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:938)
    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3682)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3293)
    at org.eclipse.jface.window.Window.runEventLoop(Window.java:820)
    at org.eclipse.jface.window.Window.open(Window.java:796)
    at org.talend.rcp.intro.Application.logUserOnProject(Unknown Source)
    at org.talend.rcp.intro.Application.start(Unknown Source)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:153)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:504)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:443)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1169)

Offline

#4 2007-11-09 16:39:26

mcoudert
Member
55 posts

mcoudert said:

Re: Erreur au démarrage de SDI

Hi Christophe,

We try to reproduce your SDI startup error without success...
FYI, we try with different JVM (ie 1.6.0_01, 1.6.0_02 and 1.6.0_03) using Windows XP 32 bits...

Could you please try with the TOS-All-V2.2.1 version and let us know what happen.

Regards,
Mathieu

Offline

#5 2007-11-10 16:52:09

cbredel
Member
3 posts

cbredel said:

Re: Erreur au démarrage de SDI

Hi,

I downloaded a new time and unzip... Now it works fine.

Maybe a download trouble ;-(

Sorry for the first message in french ( Special thanks to elemoine for the translate).

Offline

Board footer

Talend Contributor Agreement - Talend Website Privacy Policy